aboutsummaryrefslogtreecommitdiffstats
path: root/community/thunar-archive-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/thunar-archive-plugin/APKBUILD')
-rw-r--r--community/thunar-archive-plugin/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/thunar-archive-plugin/APKBUILD b/community/thunar-archive-plugin/APKBUILD
new file mode 100644
index 0000000000..9def4c8dc2
--- /dev/null
+++ b/community/thunar-archive-plugin/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar-archive-plugin
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="create and deflate archives in thunar"
+url="http://foo-projects.org/~benny/projects/thunar-archive-plugin/"
+arch="all"
+license="GPL-2.0"
+depends=
+makedepends="gtk+-dev intltool thunar-dev exo-dev"
+install=
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/thunar-plugins/thunar-archive-plugin/${pkgver%.*}/thunar-archive-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ # dont want file-roller
+ rm -f "$pkgdir"/usr/lib/xfce4/thunar-archive-plugin/file-roller.tap
+}
+
+md5sums="425f4faaace6dc7a4716a35b7795463a thunar-archive-plugin-0.3.1.tar.bz2"
+sha256sums="9ad559b0c11308f6897ad56604e5a06dc8f369f649eb20120b2d3018ef5da54c thunar-archive-plugin-0.3.1.tar.bz2"
+sha512sums="51157c2680b3fcc6b541d35fc2943a350a0354d7d5bbb5fbe8a9dcbbeaf4bf4f5fe62521b8e9a73254f70bbefc440357deade8181313da96270c280eb0464e68 thunar-archive-plugin-0.3.1.tar.bz2"