aboutsummaryrefslogtreecommitdiffstats
path: root/community/vlc/fix-missing-asm.S-for-arm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/vlc/fix-missing-asm.S-for-arm.patch')
-rw-r--r--community/vlc/fix-missing-asm.S-for-arm.patch69
1 files changed, 44 insertions, 25 deletions
diff --git a/community/vlc/fix-missing-asm.S-for-arm.patch b/community/vlc/fix-missing-asm.S-for-arm.patch
index 511650fb2e..5b363fa1e9 100644
--- a/community/vlc/fix-missing-asm.S-for-arm.patch
+++ b/community/vlc/fix-missing-asm.S-for-arm.patch
@@ -1,26 +1,45 @@
-From 29c4721b18ad422cc3cbb6aed9d321900dab0e51 Mon Sep 17 00:00:00 2001
-From: =?utf8?q?Martin=20Storsj=C3=B6?= <martin@martin.st>
-Date: Thu, 1 Mar 2018 22:20:45 +0200
-Subject: [PATCH] arm_neon: Include asm.S in distribution tarballs
-
-Signed-off-by: Thomas Guillem <thomas@gllm.fr>
-(cherry picked from commit 0d3878ef7488bab8bcb25b0f585143fea96e468f)
-Signed-off-by: Thomas Guillem <thomas@gllm.fr>
-
-Patch-Source: https://git.videolan.org/?p=vlc/vlc-3.0.git;a=commit;h=29c4721b18ad422cc3cbb6aed9d321900dab0e51
----
- modules/arm_neon/Makefile.am | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/modules/arm_neon/Makefile.am b/modules/arm_neon/Makefile.am
-index db81ec0b84..10f5c15d7c 100644
---- a/modules/arm_neon/Makefile.am
-+++ b/modules/arm_neon/Makefile.am
-@@ -28,3 +28,5 @@ neon_LTLIBRARIES = \
- libvolume_neon_plugin.la \
- libyuv_rgb_neon_plugin.la
- endif
+diff --git a/modules/arm_neon/asm.S b/modules/arm_neon/asm.S
+new file mode 100644
+index 0000000..728391e
+--- /dev/null
++++ b/modules/arm_neon/asm.S
+@@ -0,0 +1,39 @@
++/*
++ * Copyright (c) 2018 Janne Grunau <janne-libav@jannau.net>
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
++ */
+
-+EXTRA_DIST += arm_neon/asm.S
---
-2.11.0
++#ifdef __APPLE__
++# define EXTERN_ASM _
++#else
++# define EXTERN_ASM
++#endif
++
++#if defined(__APPLE__) || defined(_WIN32)
++# define HAVE_AS_ARCH_DIRECTIVE 0
++# define HAVE_AS_FPU_DIRECTIVE 0
++#else
++# define HAVE_AS_ARCH_DIRECTIVE 1
++# define HAVE_AS_FPU_DIRECTIVE 1
++#endif
++
++.macro function name
++ .globl EXTERN_ASM\name
++#ifdef __ELF__
++ .type EXTERN_ASM\name, %function
++#endif
++EXTERN_ASM\name:
++.endm