aboutsummaryrefslogtreecommitdiffstats
path: root/community/w3m/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/w3m/APKBUILD')
-rw-r--r--community/w3m/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/community/w3m/APKBUILD b/community/w3m/APKBUILD
index 127f186945..a9983da284 100644
--- a/community/w3m/APKBUILD
+++ b/community/w3m/APKBUILD
@@ -1,3 +1,5 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=w3m
pkgver=0.5.3
pkgrel=1
@@ -14,19 +16,10 @@ source="http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname
gc72.patch
w3m-0.5.3-parallel-make.patch
"
-
-prepare() {
- local i
- cd "${srcdir}/${pkgname}-${pkgver}"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $builddir
./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
@@ -45,7 +38,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $builddir
make DESTDIR="${pkgdir}" install
install -d "${pkgdir}"/usr/share/doc/"${pkgname}"