aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-battery-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'community/xfce4-battery-plugin')
-rw-r--r--community/xfce4-battery-plugin/APKBUILD40
-rw-r--r--community/xfce4-battery-plugin/fix-includes.patch19
2 files changed, 59 insertions, 0 deletions
diff --git a/community/xfce4-battery-plugin/APKBUILD b/community/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 0000000000..51224ddd1b
--- /dev/null
+++ b/community/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-battery-plugin
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="A battery monitor plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+arch="all"
+license="GPL-2.0"
+makedepends="xfce4-panel-dev libxfce4ui-dev perl-xml-parser intltool linux-headers"
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ "
+# fix-includes.patch
+# "
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ find \( -name config.sub -o -name config.guess \) -exec chmod 0755 {} \;
+ update_config_sub
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d3f5b6d3657abfba2c4c5cb3ab8ddc87f4862f24eb614cb91af48332b3082c3dce7f32eb2e3cb8a9d501ddb01c6259c4fbfbab8ed9c221633e47eb17c623cf09 xfce4-battery-plugin-1.1.0.tar.bz2"
diff --git a/community/xfce4-battery-plugin/fix-includes.patch b/community/xfce4-battery-plugin/fix-includes.patch
new file mode 100644
index 0000000000..207ac63bde
--- /dev/null
+++ b/community/xfce4-battery-plugin/fix-includes.patch
@@ -0,0 +1,19 @@
+--- a/panel-plugin/libacpi.c
++++ b/panel-plugin/libacpi.c
+@@ -29,7 +29,6 @@
+ #include <sys/types.h>
+ #include <dirent.h>
+ #include <glob.h>
+-#include <unistd.h>
+
+ #ifdef __FreeBSD__
+ #include <fcntl.h>
+@@ -55,6 +54,8 @@
+ #include <errno.h>
+
+ #endif
++
++#include <unistd.h>
+
+ #include "libacpi.h"
+