aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-clipman-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xfce4-clipman-plugin/APKBUILD')
-rw-r--r--community/xfce4-clipman-plugin/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/xfce4-clipman-plugin/APKBUILD b/community/xfce4-clipman-plugin/APKBUILD
new file mode 100644
index 0000000000..74d15223f5
--- /dev/null
+++ b/community/xfce4-clipman-plugin/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-clipman-plugin
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Clipboard manager plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+arch="all"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="libxfce4ui-dev xfce4-panel-dev libunique-dev libxtst-dev exo-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-clipman-plugin/${pkgver%.*}/xfce4-clipman-plugin-$pkgver.tar.bz2"
+
+builddir="$srcdir"/xfce4-clipman-plugin-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --enable-unique \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="f12d9e3e37a26f9dade5b76e73ac3998030112b53e7ec7b756128f7f1ee28d19a1d7b8d4a26e0ccb69aaba2f0ab2f6c4cd5a435bd1cc7efd81c05b711480eba6 xfce4-clipman-plugin-1.4.2.tar.bz2"