aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-panel
diff options
context:
space:
mode:
Diffstat (limited to 'community/xfce4-panel')
-rw-r--r--community/xfce4-panel/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/xfce4-panel/APKBUILD b/community/xfce4-panel/APKBUILD
new file mode 100644
index 0000000000..4eed5133a1
--- /dev/null
+++ b/community/xfce4-panel/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-panel
+pkgver=4.12.1
+pkgrel=2
+pkgdesc="Panel for the Xfce desktop environment"
+url="https://xfce.org/"
+arch="all"
+license="GPL-2.0+, LGPL-2.1+"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends="hicolor-icon-theme"
+depends_dev="libxfce4util-dev gtk+2.0-dev gtk+3.0-dev"
+makedepends="$depends_dev libxfce4ui-dev exo-dev garcon-dev libwnck-dev"
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd $builddir
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk3
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd $builddir
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8bdc2a560a698e7d41429b40cde51ea1bec5aba211b6ee89b46822a38176e27e332efa785d93901d598b17171c739406e7f983372aaa49177db0f868aea985a4 xfce4-panel-4.12.1.tar.bz2"