aboutsummaryrefslogtreecommitdiffstats
path: root/community/xmlsec/libressl-2.7.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/xmlsec/libressl-2.7.patch')
-rw-r--r--community/xmlsec/libressl-2.7.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/xmlsec/libressl-2.7.patch b/community/xmlsec/libressl-2.7.patch
new file mode 100644
index 0000000000..9a8240204d
--- /dev/null
+++ b/community/xmlsec/libressl-2.7.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.ac b/configure.ac
+index 3278200..0fe3a76 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -489,7 +489,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z$OPENSSL_VERSION" = "z" ; then
+ if test "z$OPENSSL_VERSION" = "z" ; then
+ AC_EGREP_CPP(yes,[
+ #include <openssl/opensslv.h>
+- #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
++ #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
+ yes
+ #endif
+ ],[
+diff --git a/include/xmlsec/openssl/crypto.h b/include/xmlsec/openssl/crypto.h
+index 96cc65b..353a2dd 100644
+--- a/include/xmlsec/openssl/crypto.h
++++ b/include/xmlsec/openssl/crypto.h
+@@ -43,7 +43,7 @@ XMLSEC_CRYPTO_EXPORT const xmlChar* xmlSecOpenSSLGetDefaultTrustedCertsFolde
+ * What version of the openssl API do we have? (also see configure.ac)
+ *
+ *******************************************************************/
+-#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
+ /* Libressl decided to take over OpenSSL version 2.0.0, likely will create
+ * issues down the road...
+ */