aboutsummaryrefslogtreecommitdiffstats
path: root/community/yarn
diff options
context:
space:
mode:
Diffstat (limited to 'community/yarn')
-rw-r--r--community/yarn/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/yarn/APKBUILD b/community/yarn/APKBUILD
index d0735c7aee..e79b01ae0f 100644
--- a/community/yarn/APKBUILD
+++ b/community/yarn/APKBUILD
@@ -8,11 +8,15 @@ url="https://yarnpkg.com/"
arch="noarch"
license="BSD-2"
depends="nodejs"
-options="!check"
source="https://yarnpkg.com/downloads/$pkgver/$pkgname-v$pkgver.tar.gz
apk-install-method.patch"
builddir="$srcdir/dist"
+check() {
+ cd "$builddir"
+ ./bin/yarn --version
+}
+
package() {
local destdir="usr/share/node_modules/$pkgname"