aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild/remove-mkalpine.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild/remove-mkalpine.patch')
-rw-r--r--main/abuild/remove-mkalpine.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/main/abuild/remove-mkalpine.patch b/main/abuild/remove-mkalpine.patch
new file mode 100644
index 0000000000..867b0033b1
--- /dev/null
+++ b/main/abuild/remove-mkalpine.patch
@@ -0,0 +1,65 @@
+commit af22a92fa6f4e787ac6c4a22bedb65b66786427a
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue Jul 20 11:31:43 2010 +0000
+
+ mkalpine: removed
+
+diff --git a/Makefile b/Makefile
+index 7f20208..da99953 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,7 @@ sysconfdir ?= /etc
+ datadir ?= $(prefix)/share/$(PACKAGE)
+ abuildrepo ?= ~/.cache/apks
+
+-SCRIPTS := abuild devbuild mkalpine buildrepo abuild-keygen \
++SCRIPTS := abuild devbuild buildrepo abuild-keygen \
+ abuild-sign newapkbuild
+ USR_BIN_FILES := $(SCRIPTS) abuild-tar
+ SAMPLES := sample.APKBUILD sample.initd sample.confd \
+diff --git a/mkalpine.in b/mkalpine.in
+deleted file mode 100755
+index e31980a..0000000
+--- a/mkalpine.in
++++ /dev/null
+@@ -1,40 +0,0 @@
+-#!/bin/sh
+-
+-# check if what we need is here
+-needed="cramfs syslinux cdrkit"
+-for i in $needed; do
+- if ! apk info -e $i; then
+- missing="$missing $i"
+- fi
+-done
+-
+-# try install the missing parts
+-if [ -n "$missing" ]; then
+- if ! sudo apk add $missing; then
+- echo "Need $missing to build alpine" >&2
+- exit 1
+- fi
+-fi
+-
+-# first look for alpine.mk in current dir. Fallback to /usr/share/abuild
+-mk=./alpine.mk
+-if ! [ -f $mk ]; then
+- mk=/usr/share/abuild/alpine.mk
+-fi
+-
+-make -f "$mk" APK_BIN= $@
+-rc=$?
+-
+-# beep when done
+-if [ $rc -eq 0 ]; then
+- for i in $(seq 0 3); do
+- echo -n -e "\007"
+- sleep 0.2
+- done
+-fi
+-
+-# uninstall the stuff we installed
+-[ -n "$missing" ] && sudo apk del $missing
+-
+-
+-exit $?