aboutsummaryrefslogtreecommitdiffstats
path: root/main/cryptsetup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cryptsetup/APKBUILD')
-rw-r--r--main/cryptsetup/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/cryptsetup/APKBUILD b/main/cryptsetup/APKBUILD
index 4a35f3b2bc..1939d9c16b 100644
--- a/main/cryptsetup/APKBUILD
+++ b/main/cryptsetup/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cryptsetup
pkgver=2.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
url="https://gitlab.com/cryptsetup/cryptsetup"
arch="all"
license="GPL-2.0-or-later"
depends=""
makedepends_build=""
-makedepends_host="lvm2-dev libressl-dev popt-dev util-linux-dev json-c-dev"
+makedepends_host="lvm2-dev libressl-dev popt-dev util-linux-dev
+ json-c-dev argon2-dev"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://www.kernel.org/pub/linux/utils/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.gz
@@ -28,6 +29,7 @@ build() {
--libdir=/lib \
--sbindir=/sbin \
--disable-static \
+ --enable-libargon2 \
--with-crypto_backend=openssl \
--with-luks2-lock-path=/run/cryptsetup # https://gitlab.com/cryptsetup/cryptsetup/issues/362
make