aboutsummaryrefslogtreecommitdiffstats
path: root/main/dejagnu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/dejagnu/APKBUILD')
-rw-r--r--main/dejagnu/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/dejagnu/APKBUILD b/main/dejagnu/APKBUILD
new file mode 100644
index 0000000000..87c264a078
--- /dev/null
+++ b/main/dejagnu/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+
+pkgname=dejagnu
+pkgver=1.6
+pkgrel=1
+pkgdesc="A framework for testing other programs"
+url="https://www.gnu.org/software/dejagnu/"
+arch="noarch"
+license="GPLv3+"
+depends="expect"
+makedepends="tcl>=8.5"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="a494dd5cde8d275b397116049c93e183f5f1731d63660ee8d2f4263b099fc5be7fbddde927fab3ccd5f000c43d50242f94bbb4d95497b915ea53be418bc145bc dejagnu-1.6.tar.gz"