aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-bh-ttf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-bh-ttf/APKBUILD')
-rw-r--r--main/font-bh-ttf/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/font-bh-ttf/APKBUILD b/main/font-bh-ttf/APKBUILD
index fa29ff8555..eaa179d079 100644
--- a/main/font-bh-ttf/APKBUILD
+++ b/main/font-bh-ttf/APKBUILD
@@ -11,8 +11,15 @@ makedepends="pkgconfig font-util-dev bdftopcf"
install=
source="http://xorg.freedesktop.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,7 +31,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" \
MKFONTDIR=: \
MKFONTSCALE=: \