aboutsummaryrefslogtreecommitdiffstats
path: root/main/nagios/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nagios/APKBUILD')
-rw-r--r--main/nagios/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/nagios/APKBUILD b/main/nagios/APKBUILD
index b53f56d12d..e8b643a193 100644
--- a/main/nagios/APKBUILD
+++ b/main/nagios/APKBUILD
@@ -22,7 +22,10 @@ _builddir="$srcdir/$pkgname"
build() {
cd "$_builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc/nagios \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -36,7 +39,8 @@ build() {
--with-nagios-user=nagios \
--with-nagios-group=nagios \
--enable-embedded-perl \
- --with-perlcache
+ --with-perlcache \
+ || return 1
make all || return 1
}