aboutsummaryrefslogtreecommitdiffstats
path: root/main/newt/parallel-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/newt/parallel-build.patch')
-rw-r--r--main/newt/parallel-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/newt/parallel-build.patch b/main/newt/parallel-build.patch
new file mode 100644
index 0000000000..5502dc982e
--- /dev/null
+++ b/main/newt/parallel-build.patch
@@ -0,0 +1,20 @@
+--- ./Makefile.in.orig 2013-10-21 09:24:07.662175351 +0000
++++ ./Makefile.in 2013-10-21 09:24:45.692593150 +0000
+@@ -111,7 +111,7 @@
+ $(LIBNEWT): $(LIBOBJS)
+ ar rv $@ $^
+
+-newt.o $(SHAREDDIR)/newt.o: newt.c Makefile
++newt.o $(SHAREDDIR)/newt.o: newt.c Makefile $(SHAREDDIR)
+
+ veryclean: clean
+ rm -f .depend *.pc
+@@ -133,7 +133,7 @@
+ ln -fs $(LIBNEWTSONAME) libnewt.$(SOEXT)
+ ln -fs $(LIBNEWTSH) $(LIBNEWTSONAME)
+
+-$(SHAREDDIR)/%.o : %.c
++$(SHAREDDIR)/%.o : %.c $(SHAREDDIR)
+ $(CC) $(SHCFLAGS) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ install: $(LIBNEWT) install-sh whiptail