aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 341e4a2dba..7d9e8896d8 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -9,6 +9,7 @@ arch="all"
license="BSD"
depends=
makedepends=""
+checkdepends="paxmark"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2
@@ -47,6 +48,13 @@ package() {
check() {
cd "$builddir"
+
+ # paxmark tests requiring JIT
+ ./pcre_jit_test &>/dev/null || ./pcretest &>/dev/null < /dev/null || true
+ paxmark -m .libs/lt-pcre_jit_test .libs/lt-pcretest
+ # skip locale specific tests
+ sed -i -e 's/do3=yes//g' RunTest
+
make check
}