aboutsummaryrefslogtreecommitdiffstats
path: root/main/utmps/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/utmps/APKBUILD')
-rw-r--r--main/utmps/APKBUILD63
1 files changed, 0 insertions, 63 deletions
diff --git a/main/utmps/APKBUILD b/main/utmps/APKBUILD
deleted file mode 100644
index 100851ebc1..0000000000
--- a/main/utmps/APKBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# Maintainer: Laurent Bercot <ska-devel@skarnet.org>
-# Contributor: Laurent Bercot <ska-devel@skarnet.org>
-pkgname=utmps
-pkgver=0.0.1.1
-pkgrel=0
-pkgdesc="A secure utmp/wtmp implementation"
-url="https://skarnet.org/software/$pkgname/"
-arch="all"
-license="ISC"
-depends="execline s6"
-depends_dev="skalibs-dev"
-makedepends="skalibs-dev"
-options="!check"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz $pkgname.initd utmpd.run wtmpd.run"
-builddir="$srcdir/$pkgname-$pkgver"
-install="$pkgname.pre-install $pkgname.pre-upgrade"
-
-build() {
- cd "$builddir"
- ./configure \
- --enable-shared \
- --enable-static \
- --disable-allstatic \
- --libdir=/usr/lib \
- --libexecdir="/lib/$pkgname" \
- --with-dynlib=/lib
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- mkdir -p "$pkgdir/etc/init.d" "$pkgdir/var/lib/$pkgname/services/utmpd" "$pkgdir/var/lib/$pkgname/services/wtmpd"
- cp -f "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
- cp -f "$srcdir/utmpd.run" "$pkgdir/var/lib/$pkgname/services/utmpd/run"
- echo 3 > "$pkgdir/var/lib/$pkgname/services/utmpd/notification-fd"
- s6-mkfifodir -g0 -- "$pkgdir/var/lib/$pkgname/services/utmpd/event"
- cp -f "$srcdir/wtmpd.run" "$pkgdir/var/lib/$pkgname/services/wtmpd/run"
- echo 3 > "$pkgdir/var/lib/$pkgname/services/wtmpd/notification-fd"
- s6-mkfifodir -g 0 -- "$pkgdir/var/lib/$pkgname/services/wtmpd/event"
- chmod 0755 "$pkgdir/etc/init.d/$pkgname" "$pkgdir/var/lib/$pkgname/services/utmpd/run" "$pkgdir/var/lib/$pkgname/services/wtmpd/run"
- mkdir -m 0700 "$pkgdir/var/lib/$pkgname/services/utmpd/supervise" "$pkgdir/var/lib/$pkgname/services/wtmpd/supervise"
- dd if=/dev/zero of="$pkgdir/var/lib/$pkgname/services/utmpd/supervise/status" bs=35 count=1
- dd if=/dev/zero of="$pkgdir/var/lib/$pkgname/services/wtmpd/supervise/status" bs=35 count=1
-}
-
-# Remove this dev() override when musl-dev doesn't own /usr/include/utmpx.h anymore.
-dev() {
- default_dev
- rm -f "$subpkgdir/usr/include/utmpx.h"
-}
-
-doc() {
- default_doc
- mkdir -p "$subpkgdir/usr/share/doc"
- cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
-}
-
-sha512sums="0a6e60356fd30000f3f17b8809b425b9040d02dcac2c489c7530044630120ddff034646cff149d427cbfaaf86e30ee03cc2ba181f9a52a42f02630ba6f8d352f utmps-0.0.1.1.tar.gz
-437d0c52ef1ecd23775990225647c2a6ca53691fb5688ffa866a0e6db177a08fe465f2e683e8b98ba668d8ddcd4ffa0fe3939f23ded276f4ca7acaa2553b10e6 utmps.initd
-0ec30284c64c6ea9f25142c5f4a643bd48b137fe85781b650104f5137ffa4dfc35ca7be3e41e3acd3403ebe1d8c5378073afa4e2f3607d3d794fcd9f98ed51c4 utmpd.run
-cba4f2ec3b8f5becf3ae57eecf584745d783046ee6cf5d116322421ad5ffd074d2955da22d31d2b5b1d05f906378aae92f221d2ac95ac21b54a361fbdc0566e7 wtmpd.run"