aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/gptfdisk/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/gptfdisk/APKBUILD b/main/gptfdisk/APKBUILD
new file mode 100644
index 0000000000..eb7c730342
--- /dev/null
+++ b/main/gptfdisk/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gptfdisk
+pkgver=0.8.8
+pkgrel=0
+pkgdesc="A text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
+arch="all"
+url="http://www.rodsbooks.com/gdisk/"
+license='GPL2'
+makedepends="ncurses-dev e2fsprogs-dev popt-dev icu-dev"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/gptfdisk-$pkgver
+build() {
+ cd "$_builddir"
+ make CXX="${CXX:-g++}" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
+}
+
+package () {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/man/man8 \
+ || return 1
+
+ for i in gdisk cgdisk sgdisk fixparts; do
+ install $i "$pkgdir"/usr/bin/ || return 1
+ install $i.8 "$pkgdir"/usr/share/man/man8/ || return 1
+ done
+}
+
+md5sums="bd47d03ec27bab5613254b5a20f72143 gptfdisk-0.8.8.tar.gz"
+sha256sums="4c31e9c0e4802079526658947ab236d3b417604a8246a418f41cdc2a8ec2be9a gptfdisk-0.8.8.tar.gz"
+sha512sums="22da28425ff06d2cca0838ff99950295c463d8557b0191efc74d4c9d819871ac635f69c62d07e93460ad07f4eb4c1ab4fd728b82374925f59783a52497a4becb gptfdisk-0.8.8.tar.gz"