aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/spl/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/main/spl/APKBUILD b/main/spl/APKBUILD
index 15a58ea8fa..194578bc3f 100644
--- a/main/spl/APKBUILD
+++ b/main/spl/APKBUILD
@@ -1,26 +1,22 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
pkgname=spl
-pkgver=0.7.5
+pkgver=0.7.8
pkgrel=0
pkgdesc="Solaris Porting Layer (userland)"
url="http://zfsonlinux.org"
arch="all !armhf"
-license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers"
-install=""
+license="GPL-2.0-or-later"
+options="!check" # No test suite
+makedepends="automake autoconf libtool linux-headers"
subpackages="$pkgname-doc"
-source="https://github.com/zfsonlinux/zfs/releases/download/zfs-$pkgver/spl-$pkgver.tar.gz"
-
-builddir="$srcdir"/spl-$pkgver
+source="https://github.com/zfsonlinux/spl/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/spl-spl-$pkgver
prepare() {
default_prepare
- update_config_sub
- update_config_guess
+ cd "$buildir"
+ autoreconf -fi
}
build() {
@@ -38,5 +34,4 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-
-sha512sums="a797ddab6841cbe9c7eacc4f276537ecb5905a694604185044e98ed017b325367a1fdd1ea6830d29d4a21ed11a8d1ff0505bda7bbd2112418db319df128141a3 spl-0.7.5.tar.gz"
+sha512sums="145ff3776db1e58e1f0fb469ca3a74aaa33686262916c42f7782ff723b2e28bea576924e87e06dbb8dd4a44788b5cb8f4ed278b2042910acb3d60a0a9b788612 spl-0.7.8.tar.gz"