aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/util-linux/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index c099d261fc..a10294acef 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -30,6 +30,8 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp
if [ -z "$BOOTSTRAP" ]; then
makedepends_host="$makedepends_host ncurses-dev python-dev"
subpackages="$subpackages py-libmount:_py"
+else
+ _bootstrap_config="--without-python"
fi
makedepends="$makedepends_build $makedepends_host"
replaces="e2fsprogs util-linux-ng"
@@ -55,6 +57,7 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
+ --with-sysroot=$CBUILDROOT \
--prefix=/usr \
--enable-raw \
--with-ncurses \
@@ -66,6 +69,7 @@ build() {
--disable-last \
--disable-sulogin \
--disable-su \
+ $_bootstrap_config \
|| return 1
make || return 1
}