aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apt-dater-host/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apt-dater-host/APKBUILD')
-rw-r--r--testing/apt-dater-host/APKBUILD23
1 files changed, 3 insertions, 20 deletions
diff --git a/testing/apt-dater-host/APKBUILD b/testing/apt-dater-host/APKBUILD
index adc245dcdd..5997903c1c 100644
--- a/testing/apt-dater-host/APKBUILD
+++ b/testing/apt-dater-host/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
pkgname=apt-dater-host
-pkgver=1.0.0
-pkgrel=5
+pkgver=1.0.1
+pkgrel=0
pkgdesc="Host helper application for apt-dater"
url="https://github.com/DE-IBH/apt-dater-host"
arch="noarch"
@@ -10,23 +10,11 @@ license="GPL-2.0-or-later"
checkdepends="bats checkbashisms"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/DE-IBH/$pkgname/archive/v$pkgver.tar.gz
- initial-support-for-alpine.patch
- try-to-use-virt-what.patch
- 0001-apk-add-some-unit-tests-called-via-make-check.patch
- 0002-apk-handle-packages-installed-with-Repository_pinnin.patch
- 0003-apk-an-alpine-package-can-be-held-back-with-as-well.patch
apt-dater-host-fix-bashisms.patch
"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- chmod a+x apk/test-apt-dater-host
-}
-
check() {
cd "$builddir"/apk
make check
@@ -42,10 +30,5 @@ package() {
install -d -m0755 "$pkgdir"/usr/share/man/man1
install -m0644 "$pkgname".1 "$pkgdir"/usr/share/man/man1
}
-sha512sums="db750d1c33e425de315ecfe4d7d1a177b64432070ce355adfe24ebf7510f4f3d64522f57578a1157394255ec4c13d5d6fd20639dfdf2a69a94f9364ec1b1a6c8 apt-dater-host-1.0.0.tar.gz
-8f427b0f6bf240b753e66e61f4ff069ae5fb46ea2c87df5b0ba6126ccb21d3b104b37af8260da0925eabedecf7e43fee2adf57fb6b1112c309c84817aa8a74c9 initial-support-for-alpine.patch
-105b10a811a39b78ed8764318bceb7c44f7dd9781f49bd7b8ce09fc7011e3dd88b41037a5a82f9b05b1324914fab4baa87c836f613cafea606554abe7b35c139 try-to-use-virt-what.patch
-d316c9cb8d465112b7c838103a6d0fe5acf437819bf3a7e8d51a2e317cded71d53a36f6db980f71f5aa789ee28c9ffbfd2af2a333e3ae16fcd4ac05cf48c84bc 0001-apk-add-some-unit-tests-called-via-make-check.patch
-ee606e48869c83b4f36515e3ffc23be1f99779aab848414601cf86722122fa2c433283dba6872571ec47af1a0b83d38f21dfa054221f7196b0273e7fce4904e5 0002-apk-handle-packages-installed-with-Repository_pinnin.patch
-bea084d448e1679e3910cb642177182a5ae75505b334b909989a4cdfaf1b5059286f90fcfcd39deb3e504a1816e5ba662e4c4c4f229493847a666396d1138f36 0003-apk-an-alpine-package-can-be-held-back-with-as-well.patch
+sha512sums="52d48ade6758cb1150be2f21ed4c9831b4254ccc749ae865321abea077737a49ff7aeefb4e643aa289d953d2847dcf83e94837fe510fa8f8bfe19cfda0fd9dbc apt-dater-host-1.0.1.tar.gz
6f695e1b1785f88217b5a32c509b5cb3c7a3f70069b042ad9770a4c1e86c4477abab2763579130f65e0c880976eb9f292bed3b42dda0d25e801696db479e55e8 apt-dater-host-fix-bashisms.patch"