aboutsummaryrefslogtreecommitdiffstats
path: root/testing/botan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/botan/APKBUILD')
-rw-r--r--testing/botan/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/botan/APKBUILD b/testing/botan/APKBUILD
index fc3ec34c7c..db06474736 100644
--- a/testing/botan/APKBUILD
+++ b/testing/botan/APKBUILD
@@ -1,19 +1,19 @@
# Contributor: tcely <tcely@users.noreply.github.com>
# Maintainer:
pkgname=botan
-_pkgreal=Botan
-pkgver=2.5.0
+pkgver=2.6.0
pkgrel=0
pkgdesc="Crypto and TLS for C++11"
url="https://botan.randombit.net/"
-arch="all !armhf"
+arch="all"
license="BSD-2-Clause"
depends=""
depends_dev="boost-dev bzip2-dev libressl-dev sqlite-dev xz-dev zlib-dev"
makedepends="$depends_dev python2"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://botan.randombit.net/releases/$_pkgreal-$pkgver.tgz"
-builddir="$srcdir/$_pkgreal-$pkgver"
+source="https://botan.randombit.net/releases/Botan-$pkgver.tgz
+ add-armv8l-alias.patch"
+builddir="$srcdir/Botan-$pkgver"
install=""
build() {
@@ -36,7 +36,9 @@ build() {
check() {
cd "$builddir"
- LD_LIBRARY_PATH=. python2 src/python/botan2.py
+ LD_LIBRARY_PATH=. PYTHONPATH="$builddir/src/python" \
+ python2 src/scripts/test_python.py
+ ./botan-test
}
package() {
@@ -46,4 +48,5 @@ package() {
rm -rf "$pkgdir"/usr/lib/python*
}
-sha512sums="51d91bcf6ba41247fbb649697e33e3a0c8ba9f35ba7865be9120c0f0efb7fa8c51fb3d922f0d5576ae1ef637188821ff4352ed45de52e0798910ee354787cdda Botan-2.5.0.tgz"
+sha512sums="2082b4aaac0802f117a5f75c67a69e6d364b436a0ebe543032e370c3f085752bbe1ca48051462066e13bd42e47573ebc532d1d45074fe406df032f33346ee645 Botan-2.6.0.tgz
+d43abb73a852e8370940dc7ef51e564c57d21365a2d5c04581ff9b5926a11e0a1c0e2f2e2821932f63649335f8606a789a3467e6ecfad4da76a2598ef5bce6ff add-armv8l-alias.patch"