aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fzy
diff options
context:
space:
mode:
Diffstat (limited to 'testing/fzy')
-rw-r--r--testing/fzy/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/fzy/APKBUILD b/testing/fzy/APKBUILD
new file mode 100644
index 0000000000..0533a8582e
--- /dev/null
+++ b/testing/fzy/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Jonathan Neuschäfer <j.neuschaefer@gmx.net>
+pkgname=fzy
+pkgver=0.9
+pkgrel=0
+pkgdesc="A better fuzzy finder"
+url="https://github.com/jhawthorn/"
+arch="all"
+license="MIT"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jhawthorn/fzy/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PREFIX="/usr"
+}
+
+check() {
+ cd "$builddir"
+ make check
+
+ # In addition, we could also require ruby here, and run "make acceptance".
+}
+
+package() {
+ cd "$builddir"
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0 fzy-0.9.tar.gz"