aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hessling-editor
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hessling-editor')
-rw-r--r--testing/hessling-editor/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/hessling-editor/APKBUILD b/testing/hessling-editor/APKBUILD
new file mode 100644
index 0000000000..bc298a4596
--- /dev/null
+++ b/testing/hessling-editor/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor:
+# Maintainer:
+pkgname=hessling-editor
+_pkgname=THE
+pkgver=3.3
+_pkgver=3.3RC1
+pkgrel=1
+pkgdesc="THE is a powerful text editor modelled on the VM/CMS text editor XEDIT with the best features of Mansfield Software's Kedit."
+url="http://hessling-editor.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="regina-rexx"
+depends_dev=
+makedepends="ncurses-dev regina-rexx"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$_pkgname-$_pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$_pkgname-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --with-rexx=regina --with-ncurses --prefix=/usr
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e46b63e533bc458f6f701983b7f2150b THE-3.3RC1.tar.gz"