aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libunwind
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libunwind')
-rw-r--r--testing/libunwind/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/testing/libunwind/APKBUILD b/testing/libunwind/APKBUILD
index e14d4e86b1..4f186c0def 100644
--- a/testing/libunwind/APKBUILD
+++ b/testing/libunwind/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Ben Pye <ben@curlybracket.co.uk>
pkgname=libunwind
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
url="http://www.nongnu.org/libunwind/"
arch="all"
license="MIT"
-depends="musl"
+depends=""
depends_dev=""
makedepends="$depends_dev linux-headers"
install=""
@@ -17,8 +17,10 @@ source="http://download.savannah.gnu.org/releases/libunwind/libunwind-$pkgver.ta
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- local i
cd "$_builddir"
+ update_config_sub || return 1
+
+ local i
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -28,7 +30,14 @@ prepare() {
build() {
cd "$_builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
make || return 1
}