aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxml++
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libxml++')
-rw-r--r--testing/libxml++/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
index a3a5858b77..5fa142ca98 100644
--- a/testing/libxml++/APKBUILD
+++ b/testing/libxml++/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libxml++
pkgver=3.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="libbxml++ is a C++ wrapper for the libxml XML parser library."
url="http://libxmlplusplus.sourceforge.net/"
arch="all"
license="GPL2"
makedepends="libxml2-dev glibmm-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver:0:3}/$pkgname-$pkgver.tar.xz"
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgveri%.[0-9]*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -21,6 +21,12 @@ build() {
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/$pkgname-${pkgver%.[0-9]*}.pc "$pkgdir"/usr/lib/pkgconfig/${pkgname%.[0-9]*}.pc
+}
+
+check() {
+ cd "$builddir"
+ make check
}
md5sums="9e95424a1c7231db91ce4058546de461 libxml++-3.0.1.tar.xz"