aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mongo-c-driver
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mongo-c-driver')
-rw-r--r--testing/mongo-c-driver/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/mongo-c-driver/APKBUILD b/testing/mongo-c-driver/APKBUILD
index 2029d45976..65c0d0165a 100644
--- a/testing/mongo-c-driver/APKBUILD
+++ b/testing/mongo-c-driver/APKBUILD
@@ -12,9 +12,13 @@ makedepends="$depends_dev autoconf automake libbson-dev libtool py3-sphinx"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/mongodb/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$pkgname-$pkgver"
+case "$CARCH" in
+ # FIXME: Tests hang on aarch64.
+ aarch64) options="!check";;
+esac
+
build() {
cd "$builddir"
SPHINX_BUILD=/usr/bin/sphinx-build-3 ./configure \