aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-log-log4perl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-log-log4perl')
-rw-r--r--testing/perl-log-log4perl/026FileApp.t.patch13
-rw-r--r--testing/perl-log-log4perl/APKBUILD24
2 files changed, 31 insertions, 6 deletions
diff --git a/testing/perl-log-log4perl/026FileApp.t.patch b/testing/perl-log-log4perl/026FileApp.t.patch
new file mode 100644
index 0000000000..07b51afc23
--- /dev/null
+++ b/testing/perl-log-log4perl/026FileApp.t.patch
@@ -0,0 +1,13 @@
+diff --git a/t/026FileApp.t b/t/026FileApp.t
+index b3ae4f4..6c3b345 100644
+--- a/t/026FileApp.t
++++ b/t/026FileApp.t
+@@ -484,7 +484,7 @@ EOT
+
+ my ($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size, $atime,$mtime,$ctime,$blksize,$blocks) = stat("${testpath}_1");
+
+- is($mode & 07777,0750); #Win32 777
++ is($mode & 0777,0750); #Win32 777
+
+ ($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size, $atime,$mtime,$ctime,$blksize,$blocks) = stat($testmkpathfile);
+
diff --git a/testing/perl-log-log4perl/APKBUILD b/testing/perl-log-log4perl/APKBUILD
index 1814011929..caf4e54bff 100644
--- a/testing/perl-log-log4perl/APKBUILD
+++ b/testing/perl-log-log4perl/APKBUILD
@@ -1,25 +1,32 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-log-log4perl
_pkgreal=Log-Log4perl
-pkgver=1.37
+pkgver=1.46
pkgrel=0
pkgdesc="Log4j implementation for Perl"
url="http://search.cpan.org/dist/Log-Log4perl/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=""
+cpanmakedepends="perl-log-dispatch perl-dbi"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/$_pkgreal-$pkgver.tar.gz
+ 026FileApp.t.patch"
_builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
+ local i
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
@@ -34,4 +41,9 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="56325c6c39abe33f440354f2e48afa78 Log-Log4perl-1.37.tar.gz"
+md5sums="d247d2327d7f32dca09cbeb51a953fc5 Log-Log4perl-1.46.tar.gz
+2d147d25e318afb35df0c858a932191d 026FileApp.t.patch"
+sha256sums="31011a17c04e78016e73eaa4865d0481d2ffc3dc22813c61065d90ad73c64e6f Log-Log4perl-1.46.tar.gz
+0048ba7cd7be35e3eb160e39ccaa52fa30640fc0de24a842a38a72d5d449c8a3 026FileApp.t.patch"
+sha512sums="f8e9b75eb8a3d0076069b370ab2ec455a9425fa7056e40ba2ba3d3a423489d650e1a28fd5d5e7bca57511a63f6a9dc2b438dacb10b028a955ecc3516fcf3ae45 Log-Log4perl-1.46.tar.gz
+c82d96d4c1d7778a4338801f1a35c4d1b8cf2005798d22c378bcabb3c3743b2389c96b22dee119b9e345402d6d781b570c384428693cf4cf32cae3a9bbff2a6d 026FileApp.t.patch"