aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pygal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-pygal/APKBUILD')
-rw-r--r--testing/py-pygal/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/py-pygal/APKBUILD b/testing/py-pygal/APKBUILD
new file mode 100644
index 0000000000..5dcaf53d40
--- /dev/null
+++ b/testing/py-pygal/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py-pygal
+_pkgname=pygal
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="pygal is a dynamic SVG charting library written in python"
+url="https://pygal.org"
+arch="noarch"
+license="LGPL-3.0-or-later"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5cb95ca5c0cf74ae476953f3503154a305a0b5e42c69191b0b46f6e6cfea8c806713fe175329a69b393654d055997b2063cf3b641e91009a2b7bef219bb49ddb pygal-2.4.0.tar.gz"