aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-qt/APKBUILD')
-rw-r--r--testing/py-qt/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/testing/py-qt/APKBUILD b/testing/py-qt/APKBUILD
index a350493581..c5224844b5 100644
--- a/testing/py-qt/APKBUILD
+++ b/testing/py-qt/APKBUILD
@@ -7,26 +7,29 @@ pkgrel=0
pkgdesc="A set of Python bindings for the Qt toolkit"
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
arch="all"
-license="GPL"
+license="GPL2+"
depends="py-sip"
depends_dev="python-dev py-dbus-dev phonon-dev qt-dev py-sip-dev libx11-dev"
makedepends="$depends_dev"
subpackages=""
-install=
+install=""
source="http://sourceforge.net/projects/pyqt/files/PyQt4/PyQt-$pkgver/PyQt-x11-gpl-$pkgver.tar.gz"
+
+_builddir="${srcdir}/PyQt-x11-gpl-${pkgver}"
build() {
- cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
+ cd "$_builddir"
python configure.py \
--confirm-license \
-v /usr/share/sip \
--qsci-api
# Thanks Gerardo for the rpath fix
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
- make
+ make || return 1
}
+
package(){
- cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install || return 1
}
md5sums="8b13d2ab64e4d2fd0037b81b7e78c15c PyQt-x11-gpl-4.10.3.tar.gz"