aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tappy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-tappy/APKBUILD')
-rw-r--r--testing/py-tappy/APKBUILD45
1 files changed, 0 insertions, 45 deletions
diff --git a/testing/py-tappy/APKBUILD b/testing/py-tappy/APKBUILD
deleted file mode 100644
index 3b5d222581..0000000000
--- a/testing/py-tappy/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=py-tappy
-_pkgname=tap.py
-pkgver=2.4
-pkgrel=1
-pkgdesc="Python Test Anything Protocol (TAP) tools"
-url="https://github.com/python-tap/tappy"
-arch="noarch"
-license="BSD-2-Clause"
-makedepends="python2-dev python3-dev py-setuptools py-babel"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/tap.py/tap.py-${pkgver}.tar.gz"
-options="!check" # no test suite
-builddir="$srcdir/tap.py-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-
-
-sha512sums="7c843c40f0029bb122fdafec0f5416164b77fac69142c2308a6d815f2f409cddb33c5a08547409e278f06036e21cb2a53cbd3263c23f59c6618c12c201b8209c py-tappy-2.4.tar.gz"