aboutsummaryrefslogtreecommitdiffstats
path: root/testing/unicode-emoji/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/unicode-emoji/APKBUILD')
-rw-r--r--testing/unicode-emoji/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/unicode-emoji/APKBUILD b/testing/unicode-emoji/APKBUILD
new file mode 100644
index 0000000000..f1a05e53a3
--- /dev/null
+++ b/testing/unicode-emoji/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+pkgname=unicode-emoji
+pkgver=11.0
+pkgrel=0
+pkgdesc="Unicode Emoji Data Files"
+arch="noarch"
+license="BSD"
+url="http://www.unicode.org/emoji/"
+source="emoji-data-$pkgver.txt::http://www.unicode.org/Public/emoji/$pkgver/emoji-data.txt
+ emoji-sequences-$pkgver.txt::http://www.unicode.org/Public/emoji/$pkgver/emoji-sequences.txt
+ emoji-test-$pkgver.txt::http://www.unicode.org/Public/emoji/$pkgver/emoji-test.txt
+ emoji-variation-sequences-$pkgver.txt::http://www.unicode.org/Public/emoji/$pkgver/emoji-variation-sequences.txt
+ emoji-zwj-sequences-$pkgver.txt::http://www.unicode.org/Public/emoji/$pkgver/emoji-zwj-sequences.txt"
+builddir="$srcdir"
+
+package() {
+ cd "$builddir"
+
+ for _f in data sequences test variation-sequences zwj-sequences; do
+ install -Dm644 emoji-$_f-$pkgver.txt "$pkgdir/usr/share/unicode/emoji/emoji-$_f.txt"
+ done
+}
+sha512sums="501847414275564c7753b7d2b8e45cdfbf9fe96a96f0f3eea81f34c480da551b317b432ca426f6441c95eea520992e8888ead749e9c60da38233afd159d9b555 emoji-data-11.0.txt
+c9af23e0738350b6d61691498ac82cccec970bb2cd4a0c5d6fab6c86fef742c09c6a83f50124c1f98c285e706d145786bb29cbf4339ff1a01c75ad7515b159a6 emoji-sequences-11.0.txt
+89c5a0f2eb460234e50dcc0fc904fbb254a1c0afa54b5bb672032f01764e0bed3624d1a4cd5627c83fcf1ea1347c9e3baaca05b2c685890afa505763baf8be79 emoji-test-11.0.txt
+a0a487ef43d9cd49ff2ced654794e7190f357b00dd70ec9b84e640181dc5b2df44b2063aa4b16447d00815094155b24531f115e9121c51c95635b0af4b043643 emoji-variation-sequences-11.0.txt
+a2a50cd5451d3ba1da0f3b46e18a10d621ead0372599b98dad0fd47fdb271407f72bd72854136c93311b13950cedc2b1594f06d460e551ab120ed30ba8abce4d emoji-zwj-sequences-11.0.txt"