aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-cppo/APKBUILD6
-rw-r--r--testing/ocaml-menhir/APKBUILD2
-rw-r--r--testing/ocaml-migrate-parsetree/APKBUILD6
-rw-r--r--testing/reason/APKBUILD5
4 files changed, 10 insertions, 9 deletions
diff --git a/testing/ocaml-cppo/APKBUILD b/testing/ocaml-cppo/APKBUILD
index f10af49da0..af5dc5f8f8 100644
--- a/testing/ocaml-cppo/APKBUILD
+++ b/testing/ocaml-cppo/APKBUILD
@@ -3,12 +3,12 @@
pkgname=ocaml-cppo
_pkgname=cppo
pkgver=1.6.4
-pkgrel=3
+pkgrel=4
pkgdesc="C-style preprocessor for OCaml"
url="https://github.com/mjambon/cppo"
arch="all !x86 !armhf !s390x" # limited by ocaml
license="BSD-3-Clause"
-makedepends="dune ocaml ocamlbuild ocaml-findlib opam"
+makedepends="dune ocaml ocaml-ocamlbuild-dev ocaml-findlib opam"
options="textrels" # needed for ppc64le
subpackages="$pkgname-dev $pkgname-ocamlbuild"
source="$pkgname-$pkgver.tar.gz::https://github.com/mjambon/$_pkgname/archive/v$pkgver.tar.gz
@@ -46,7 +46,7 @@ package() {
ocamlbuild() {
pkgdesc="$pkgdesc (Ocamlbuild plugin)"
- depends="ocaml-runtime ocamlbuild"
+ depends="ocaml-runtime ocaml-ocamlbuild"
mkdir -p "$subpkgdir"/usr/lib/ocaml
mv "$pkgdir"/usr/lib/ocaml/${_pkgname}_ocamlbuild \
diff --git a/testing/ocaml-menhir/APKBUILD b/testing/ocaml-menhir/APKBUILD
index 82c673b205..1585163cef 100644
--- a/testing/ocaml-menhir/APKBUILD
+++ b/testing/ocaml-menhir/APKBUILD
@@ -9,7 +9,7 @@ pkgdesc="LR(1) parser generator for OCaml"
url="http://gallium.inria.fr/~fpottier/menhir/"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
license="GPL-2.0-only"
-makedepends="ocaml ocamlbuild ocaml-findlib"
+makedepends="ocaml ocaml-findlib ocaml-ocamlbuild-dev ocamlbuild"
options="!check" # no tests provided
subpackages="$pkgname-dev $pkgname-doc"
source="http://gallium.inria.fr/~fpottier/menhir/$_pkgname-$pkgver.tar.gz"
diff --git a/testing/ocaml-migrate-parsetree/APKBUILD b/testing/ocaml-migrate-parsetree/APKBUILD
index 311e28f892..6d5a28e304 100644
--- a/testing/ocaml-migrate-parsetree/APKBUILD
+++ b/testing/ocaml-migrate-parsetree/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-migrate-parsetree
pkgver=1.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Convert OCaml parsetrees between different major versions"
url="https://github.com/ocaml-ppx/ocaml-migrate-parsetree"
arch="all !x86 !armhf !s390x" # limited by ocaml
license="LGPL-2.1-only-WITH-linking-exception"
depends="ocaml-result ocaml-runtime"
makedepends="dune ocaml ocaml-compiler-libs ocaml-findlib ocaml-result-dev
- ocamlbuild opam"
+ ocaml-ocamlbuild-dev opam"
options="textrels" # ppc64le (?!)
subpackages="$pkgname-dev $pkgname-doc $pkgname-ocamlbuild"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml-ppx/$pkgname/archive/v$pkgver.tar.gz"
@@ -53,7 +53,7 @@ package() {
ocamlbuild() {
pkgdesc="$pkgdesc (ocamlbuild plugin)"
- depends="$pkgname=$pkgver-r$pkgrel ocamlbuild"
+ depends="$pkgname=$pkgver-r$pkgrel ocaml-ocamlbuild"
mkdir -p "$subpkgdir"/usr/lib/ocaml
mv "$pkgdir"/usr/lib/ocaml/$pkgname-ocamlbuild "$subpkgdir"/usr/lib/ocaml/
diff --git a/testing/reason/APKBUILD b/testing/reason/APKBUILD
index bdb681f6fb..a8843f6c90 100644
--- a/testing/reason/APKBUILD
+++ b/testing/reason/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=reason
pkgver=3.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Simple, fast & type safe code that leverages the JavaScript & OCaml ecosystems"
url="http://reasonml.github.io/"
# x86, armhf, s390x: limited by ocaml aport
@@ -20,6 +20,7 @@ makedepends="
ocaml-menhir-dev=~$_menhirver
ocaml-merlin-extend-dev
ocaml-migrate-parsetree-dev
+ ocaml-ocamlbuild-dev
ocaml-result-dev
ocaml-utop-dev
ocamlbuild
@@ -115,7 +116,7 @@ reactjs() {
rebuild() {
pkgdesc="Simple build system for Reason based on OCamlbuild"
- depends="$pkgname ocamlbuild"
+ depends="$pkgname ocaml-ocamlbuild"
_submv usr/bin/rebuild
}