aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/fbida/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/testing/fbida/APKBUILD b/testing/fbida/APKBUILD
index 7f95490244..332d106f3b 100644
--- a/testing/fbida/APKBUILD
+++ b/testing/fbida/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=fbida
pkgver=2.10
-pkgrel=4
+pkgrel=5
pkgdesc="Few applications to display and elementary edit images"
url="http://www.kraxel.org/blog/linux/$pkgname/"
arch="all"
@@ -30,14 +30,21 @@ _tool() {
local name=$(echo $subpkgname | cut -d '-' -f2)
pkgdesc="$name tool from $pkgname"
- depends="$pkgname"
- if [ "${name}" = "fbgs" ]; then
- depends="$depends $pkgname-fbi ghostscript"
+ depends=""
+ if [ "$name" = "fbgs" ]; then
+ depends="$pkgname-fbi ghostscript"
fi
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/$name \
"$subpkgdir"/usr/bin/$name || return 1
+
+ if [ "$name" = "ida" ]; then
+ mv "$pkgdir"/etc/ "$subpkgdir"/etc/ || return 1
+ fi
+
+ rmdir "$pkgdir"/usr/bin/ 2>/dev/null || true
+ rmdir "$pkgdir"/usr/ 2>/dev/null || true
}
md5sums="09460b964b58c2e39b665498eca29018 fbida-2.10.tar.gz"