aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/gdnsd/APKBUILD43
-rw-r--r--testing/gdnsd/gdnsd.pre-install5
2 files changed, 48 insertions, 0 deletions
diff --git a/testing/gdnsd/APKBUILD b/testing/gdnsd/APKBUILD
new file mode 100644
index 0000000000..e353e12c69
--- /dev/null
+++ b/testing/gdnsd/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gdnsd
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="Geographic Authoritative DNS server"
+url="http://code.google.com/p/gdnsd/"
+arch="all"
+license="GPL-3"
+depends=""
+depends_dev=""
+makedepends="libev-dev libcap-dev"
+install="$pkgname.pre-install"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://gdnsd.googlecode.com/files/gdnsd-$pkgver.tar.xz"
+
+_builddir="$srcdir"/gdnsd-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/gdnsd/*.la
+}
+
+md5sums="082f874d24cdc7073950ed6294f8d39b gdnsd-1.6.2.tar.xz"
diff --git a/testing/gdnsd/gdnsd.pre-install b/testing/gdnsd/gdnsd.pre-install
new file mode 100644
index 0000000000..66de81a2e1
--- /dev/null
+++ b/testing/gdnsd/gdnsd.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+addgroup gdnsd 2>/dev/null
+adduser -S -H -h /dev/null -s /bin/false -D -G gdnsd gdnsd 2>/dev/null
+exit 0