aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/slurm/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/testing/slurm/APKBUILD b/testing/slurm/APKBUILD
index 4b61db8a59..b08e54aced 100644
--- a/testing/slurm/APKBUILD
+++ b/testing/slurm/APKBUILD
@@ -21,12 +21,9 @@ build() {
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- # Optimizations beyond -O0 result in the binary failing to execute past the help
- # screen. Upon execution, the failing binary will exit producing the message:
- # "Illegal instruction"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS="${CFLAGS/-Os/-O0} -Wno-aggressive-loop-optimizations" \
+ -DCMAKE_C_FLAGS="${CFLAGS} -Wno-aggressive-loop-optimizations" \
${CMAKE_CROSSOPTS}
make
}