aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-libapreq2/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/testing/perl-libapreq2/APKBUILD b/testing/perl-libapreq2/APKBUILD
index 84fdffff5d..6f1b7d0d20 100644
--- a/testing/perl-libapreq2/APKBUILD
+++ b/testing/perl-libapreq2/APKBUILD
@@ -17,27 +17,24 @@ makedepends="perl-extutils-xsbuilder perl-dev libtool apache2-dev apache2-mod-pe
source="http://search.cpan.org/CPAN/authors/id/I/IS/ISAAC/$_pkgreal-$pkgver.tar.gz
libapreq2-2.08-doc.patch
$pkgname.conf"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return 1
+ update_config_guess || return 1
}
build() {
- cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL --with-apache2-apxs=/usr/bin/apxs \
- --with-apache2-httpd=/usr/sbin/httpd
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL \
+ --with-apache2-apxs=/usr/bin/apxs \
+ --with-apache2-httpd=/usr/sbin/httpd || return 1
make || return 1
}
package() {
- cd $_builddir
+ cd "$builddir"
make DESTDIR="$pkgdir" INSTALLDIRS="vendor" install
install -Dm644 "$srcdir"/$pkgname.conf \
"$pkgdir"/etc/apache2/conf.d/perl-libapreq2.conf || return 1