aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/mozjs60/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/mozjs60/APKBUILD b/testing/mozjs60/APKBUILD
index c9977ba60c..d5f6fbaead 100644
--- a/testing/mozjs60/APKBUILD
+++ b/testing/mozjs60/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=mozjs60
pkgver=60.0.2
-pkgrel=0
+_majver=${pkgver%%.*}
+pkgrel=1
pkgdesc="standalone mozilla javascript engine"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38"
arch="all !armhf !armv7"
license="LGPL"
depends=""
depends_dev="icu-dev nspr-dev libffi-dev readline-dev"
-makedepends="$depends_dev python2 perl sed autoconf2.13 linux-headers"
+makedepends="$depends_dev zlib-dev python2 perl sed autoconf2.13 linux-headers"
subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
0001-silence-sandbox-violations.patch
@@ -49,6 +50,14 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/*.ajs
+
+ # temp fix for mozjs60 not installing headers into the right place
+ mkdir -p "$pkgdir"/usr/include/mozjs-$_majver
+ mv "$pkgdir"/usr/include/double-conversion \
+ "$pkgdir"/usr/include/js \
+ "$pkgdir"/usr/include/mozilla \
+ "$pkgdir"/usr/include/*.h \
+ "$pkgdir"/usr/include/mozjs-$_majver/
}
sha512sums="c147517e37ecb6340dab29f4bcbaeb18450eda0fbd2bdfda1ab0c160de9ad33572113866c1ed4feba6a77bec432a2e02fb5cbcceb73e4a45ceef308f04d2b836 firefox-60.0.2esr.source.tar.xz