aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/confd/APKBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/testing/confd/APKBUILD b/testing/confd/APKBUILD
index 04bd95c438..ea65f82f13 100644
--- a/testing/confd/APKBUILD
+++ b/testing/confd/APKBUILD
@@ -1,37 +1,35 @@
# Contributor: tang0th <tang0th@gmx.com>
+# Contributor: fchavant <francois@lightcurve.io>
# Maintainer:
pkgname=confd
-pkgver=0.12.0_alpha3
-_ver=${pkgver/_/-}
+pkgver=0.16.0
pkgrel=0
pkgdesc="Manage local application configuration files using templates and data from etcd or consul"
url="http://confd.io"
arch="all"
-license="BSD"
+license="MIT"
depends=""
-depends_dev=""
-makedepends="$depends_dev go"
+makedepends="go"
install=""
subpackages=""
-source="$pkgname-$_ver.tar.gz::https://github.com/kelseyhightower/$pkgname/archive/v$_ver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kelseyhightower/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$_ver"
build() {
- cd "$srcdir"
- export GOPATH="$PWD"
- export GO15VENDOREXPERIMENT=1
-
- mkdir -p src/github.com/kelseyhightower/
- cp -r "$builddir" src/github.com/kelseyhightower/confd
+ export GOPATH="$srcdir"
+ mkdir -p "$GOPATH/src/github.com/kelseyhightower"
+ mv "$srcdir/$pkgname-$pkgver" "$GOPATH/src/github.com/kelseyhightower/confd"
+ cd "$GOPATH/src/github.com/kelseyhightower/confd"
+ make
+}
- go install -v github.com/kelseyhightower/confd
+check() {
+ export GOPATH="$srcdir"
+ cd "$GOPATH/src/github.com/kelseyhightower/confd"
+ make test
}
package() {
- cd "$srcdir"
- install -Dm755 bin/confd "$pkgdir"/usr/bin/confd || return 1
+ install -Dm755 "$srcdir/src/github.com/kelseyhightower/confd/bin/confd" "$pkgdir/usr/bin/confd"
}
-md5sums="1420665b612d994442e3914ab2c8f4a7 confd-0.12.0-alpha3.tar.gz"
-sha256sums="b679b35afb593bd9472cbf35c778829288c85c7b92678747d3a059ea0d74c16c confd-0.12.0-alpha3.tar.gz"
-sha512sums="4feb81952a5cd2fcb8250cf5df93b6ceeb9a2e5173f45f7c5cbdcd2de59acf7d85a60c1513520c601e7b7a1257d26c912877eaac53aafe9e4e278e4e9cc6ab15 confd-0.12.0-alpha3.tar.gz"
+sha512sums="eafabf85d1d7193847a78dcfde7b9961bdf5b634165d27acc760aff6e4ef79cac9688abdfcac049773a28f997f87ea94e6a7606ee7f7d7aaaeaa8ba67f7e48b7 confd-0.16.0.tar.gz"