aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/php-xcache/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/php-xcache/APKBUILD b/testing/php-xcache/APKBUILD
new file mode 100644
index 0000000000..882305fa0b
--- /dev/null
+++ b/testing/php-xcache/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=php-xcache
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="php opcode cacher"
+url="http://xcache.lighttpd.net/"
+arch="all"
+license="BSD"
+depends="zendframework"
+depends_dev=""
+makedepends="$depends_dev php-dev autoconf automake flex bison gawk"
+install=""
+subpackages=""
+source="http://xcache.lighttpd.net/pub/Releases/$pkgver/xcache-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xcache-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize --clean && phpize || return 1
+ ./configure \
+ --prefix=/usr \
+ --enable-xcache \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ || return 1
+ make -j1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 install INSTALL_ROOT="$pkgdir"
+}
+
+md5sums="45086010bc4f82f506c08be1c556941b xcache-3.0.1.tar.bz2"