aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/beecrypt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/beecrypt/APKBUILD')
-rw-r--r--unmaintained/beecrypt/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/beecrypt/APKBUILD b/unmaintained/beecrypt/APKBUILD
new file mode 100644
index 0000000000..a1a2aa8435
--- /dev/null
+++ b/unmaintained/beecrypt/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=beecrypt
+pkgver=4.2.1
+pkgrel=2
+pkgdesc="A general-purpose cryptography library"
+url="http://sourceforge.net/projects/beecrypt"
+arch="all"
+license="LGPL2+"
+makedepends="libtool m4"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LIBS=-lgomp ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-threads \
+ --enable-shared \
+ --without-java \
+ --without-python \
+ --with-cplusplus=no
+ make libaltdir=/usr/lib
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make libaltdir=/usr/lib DESTDIR="$pkgdir" install
+}
+
+sha512sums="59995d53c024efe6344a21ac0d6d55fbe652488a4a22cc6719f9fc3851d56697fa8738937d48aa1e6f9ebe749de61ac3c79a5f0cea793872213c3bdf922e71bc beecrypt-4.2.1.tar.gz"