aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-io-async-loop-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/perl-io-async-loop-glib/APKBUILD')
-rw-r--r--unmaintained/perl-io-async-loop-glib/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/perl-io-async-loop-glib/APKBUILD b/unmaintained/perl-io-async-loop-glib/APKBUILD
new file mode 100644
index 0000000000..f92781695f
--- /dev/null
+++ b/unmaintained/perl-io-async-loop-glib/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-io-async-loop-glib
+_pkgreal=IO-Async-Loop-Glib
+pkgver=0.21
+pkgrel=0
+pkgdesc="use C<IO::Async> with F<Glib> or F<GTK>"
+url="http://search.cpan.org/dist/IO-Async-Loop-Glib/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-glib perl-io-async"
+cpanmakedepends="perl-io-async"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends perl-test-pod perl-test-fatal
+ perl-test-refcount"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="b52b73a1cabf25ca585890de74f1ef6d IO-Async-Loop-Glib-0.21.tar.gz"
+sha256sums="6ee1c0ad57946f9e41c4f32a0ca8ad4ff1cc460a6dd69ef5c0f6cc002c6d2029 IO-Async-Loop-Glib-0.21.tar.gz"
+sha512sums="6cb8c1dc8179fa92ee77ad3ed083be417d91740a34e924e53bc884104d4604eaf8ea258b2c5f0b289e48fbb1ee0fae2bb5b6f9aa0a9052c174824d719e3e4c52 IO-Async-Loop-Glib-0.21.tar.gz"