aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/plymouth/APKBUILD61
-rw-r--r--unmaintained/plymouth/plymouth-rpmatch.patch17
2 files changed, 0 insertions, 78 deletions
diff --git a/unmaintained/plymouth/APKBUILD b/unmaintained/plymouth/APKBUILD
deleted file mode 100644
index c71a05ab7b..0000000000
--- a/unmaintained/plymouth/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=plymouth
-pkgver=0.8.3
-pkgrel=0
-pkgdesc="graphical bootsplash on linux"
-url="http://www.freedesktop.org/wiki/Software/Plymouth"
-arch="all"
-license="GPL"
-depends=""
-depends_dev="pango-dev
- gtk+-dev
- libpng-dev
- libdrm-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-x11 $pkgname-log-viewer:logviewer"
-source="http://www.freedesktop.org/software/plymouth/releases/plymouth-$pkgver.tar.bz2
- plymouth-rpmatch.patch"
-
-_builddir="$srcdir"/plymouth-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --with-system-root-install \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-
- rm -f "$pkgdir"/usr/lib/plymouth/*.la
-}
-x11() {
- mkdir -p "$subpkgdir"/usr/lib/plymouth/renderers
- mv "$pkgdir"/usr/lib/plymouth/renderers/x11.so "$subpkgdir"/usr/lib/plymouth/renderers
-}
-
-logviewer() {
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/plymouth-log-viewer "$subpkgdir"/usr/bin
-}
-
-md5sums="a479180467b21dd1c5477160d5a1fd35 plymouth-0.8.3.tar.bz2
-7d342aa2f011833647f1c696007b190c plymouth-rpmatch.patch"
diff --git a/unmaintained/plymouth/plymouth-rpmatch.patch b/unmaintained/plymouth/plymouth-rpmatch.patch
deleted file mode 100644
index f6e1948747..0000000000
--- a/unmaintained/plymouth/plymouth-rpmatch.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- plymouth-0.8.3.orig/src/libply/ply-command-parser.c
-+++ plymouth-0.8.3/src/libply/ply-command-parser.c
-@@ -671,6 +671,14 @@
- return argument[0] == '-' && argument[1] == '-';
- }
-
-+static inline int
-+rpmatch (const char *response)
-+{
-+ /* Test against "^[yY]" and "^[nN]", hardcoded to avoid requiring regex */
-+ return (*response == 'y' || *response == 'Y' ? 1
-+ : *response == 'n' || *response == 'N' ? 0 : -1);
-+}
-+
- static bool
- ply_command_option_read_arguments (ply_command_option_t *option,
- ply_list_t *arguments)