summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-31 05:59:28 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-31 05:59:28 +0000
commit0c6679fb0d31889aa2d2fae23bcd84cfddd6317e (patch)
treecbc5ff92d41e9fa9f6ef5fc600599719a8da17c1
parent9e1ebaaf8ad4fdaa601e59b8276979dc5f1091d6 (diff)
downloadaports-0c6679fb0d31889aa2d2fae23bcd84cfddd6317e.tar.bz2
aports-0c6679fb0d31889aa2d2fae23bcd84cfddd6317e.tar.xz
testing/py-tracing: new aport
-rw-r--r--testing/py-tracing/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-tracing/APKBUILD b/testing/py-tracing/APKBUILD
new file mode 100644
index 000000000..67691053c
--- /dev/null
+++ b/testing/py-tracing/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=py-tracing
+_pkgname=${pkgname#py-}
+pkgver=0.8
+pkgrel=0
+pkgdesc="Debug log/trace messages"
+url="http://liw.fi/tracing/"
+arch="noarch"
+license="GPL3+"
+depends="python"
+depends_dev=""
+makedepends="py-setuptools"
+install=""
+subpackages=""
+source="http://code.liw.fi/debian/pool/main/p/python-tracing/python-tracing_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/python-$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9f449746b2ae19ca62bca5363ae0b432 python-tracing_0.8.orig.tar.gz"
+sha256sums="808a064cc5fd1972fb07a7d72b4069cbff284ac7077bcd90eb2ce79d8b5c9ed0 python-tracing_0.8.orig.tar.gz"
+sha512sums="9a5262ce63dbcafff83a75586e90be280ff41f902d9f71f4274dac944db4196c6a5777e290ca5e49aa010fb3129d5352d8c10a554918375557525b9a56ac9096 python-tracing_0.8.orig.tar.gz"