summaryrefslogtreecommitdiffstats
path: root/main/busybox/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-20 13:48:48 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-20 13:48:48 +0000
commit1d147a1722e89b7174a9ff37e81ca619a87f31b4 (patch)
tree7f18bee5055b9efcd286377889b1b152c1921012 /main/busybox/APKBUILD
parent1c618e9658adaec86ff79f6c677a7254c4722064 (diff)
downloadaports-1d147a1722e89b7174a9ff37e81ca619a87f31b4.tar.bz2
aports-1d147a1722e89b7174a9ff37e81ca619a87f31b4.tar.xz
main/busybox: use CLIBC
Diffstat (limited to 'main/busybox/APKBUILD')
-rw-r--r--main/busybox/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index b68921da3..e89ad7bf7 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -54,7 +54,7 @@ build() {
-e "s/.*CONFIG_STATIC.*/CONFIG_STATIC=y/" \
"$_config" > .config
# musl does not support GNU regex
- [ "${CTARGET#*musl}" != "$CTARGET" ] && sed -i \
+ [ "$CLIBC" = musl ] && sed -i \
-e "s/CONFIG_EXTRA_COMPAT=y/CONFIG_EXTRA_COMPAT=n/" \
.config
make -C "$_sdir" O="$PWD" silentoldconfig || return 1
@@ -65,7 +65,7 @@ build() {
cd "$_dyndir"
msg "Building dynamic busybox"
cp "$_config" .config
- [ "${CTARGET#*musl}" != "$CTARGET" ] && sed -i \
+ [ "$CLIBC" = musl ] && sed -i \
-e "s/CONFIG_EXTRA_COMPAT=y/CONFIG_EXTRA_COMPAT=n/" \
.config
make -C "$_sdir" O="$PWD" silentoldconfig || return 1