summaryrefslogtreecommitdiffstats
path: root/main/nfs-utils/nfsmount.initd
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-07-14 15:39:29 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-07-14 15:39:29 +0000
commit6e8020140bbfb5e42802eed7c1491e675924cc01 (patch)
treecc54f3cce7238609561da3b2de59e2d3780c1085 /main/nfs-utils/nfsmount.initd
parent4ae2c3d81c309f93d2c41e22e71c5cf445123896 (diff)
parentdaa6e0d05fff7a0d1216fd6719e32d5426b24e8b (diff)
downloadaports-6e8020140bbfb5e42802eed7c1491e675924cc01.tar.bz2
aports-6e8020140bbfb5e42802eed7c1491e675924cc01.tar.xz
Merge remote branch 'alpine/master'
Conflicts: main/man-pages/APKBUILD
Diffstat (limited to 'main/nfs-utils/nfsmount.initd')
-rw-r--r--main/nfs-utils/nfsmount.initd42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/nfs-utils/nfsmount.initd b/main/nfs-utils/nfsmount.initd
new file mode 100644
index 000000000..9ae2c520d
--- /dev/null
+++ b/main/nfs-utils/nfsmount.initd
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfsmount.initd,v 1.13 2009/01/31 22:15:02 vapier Exp $
+
+[ -e /etc/conf.d/nfs ] && . /etc/conf.d/nfs
+
+depend() {
+ local myneed=""
+ if [ -e /etc/fstab ] ; then
+ awk '!/^[[:space:]]*#/ && $3 == "nfs4" { exit ($4 ~ /sec=krb/ ? 10 : 20) }' /etc/fstab
+ local ret=$?
+ [ ${ret} -eq 10 ] && myneed="${myneed} rpc.gssd"
+ [ ${ret} -eq 20 ] && myneed="${myneed} rpc.idmapd"
+ fi
+ config /etc/fstab
+ need net portmap rpc.statd ${myneed}
+ use ypbind dns rpc.idmapd rpc.gssd
+}
+
+start() {
+ if [ -x /usr/sbin/sm-notify ] ; then
+ ebegin "Starting NFS sm-notify"
+ /usr/sbin/sm-notify ${OPTS_SMNOTIFY}
+ eend $?
+ fi
+
+ # Make sure nfs support is loaded in the kernel #64709
+ if [ -e /proc/modules ] && ! grep -qs 'nfs$' /proc/filesystems ; then
+ modprobe -q nfs
+ fi
+
+ ebegin "Mounting NFS filesystems"
+ mount -a -t nfs,nfs4
+ eend $?
+}
+
+stop() {
+ ebegin "Unmounting NFS filesystems"
+ umount -a -t nfs,nfs4
+ eend $?
+}