summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-31 06:20:02 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-31 06:24:11 +0000
commit14d535ae85a7e8d8dd6cbbcbbe33e06e48d8a0d9 (patch)
tree25ae65963967dffb8786b2c4bc0018d081c1adf4 /main
parent7422da33f54d18899e30bb19c6369eadf89f97c9 (diff)
downloadaports-14d535ae85a7e8d8dd6cbbcbbe33e06e48d8a0d9.tar.bz2
aports-14d535ae85a7e8d8dd6cbbcbbe33e06e48d8a0d9.tar.xz
main/py-ttystatus: moved from testing
Diffstat (limited to 'main')
-rw-r--r--main/py-ttystatus/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/py-ttystatus/APKBUILD b/main/py-ttystatus/APKBUILD
new file mode 100644
index 000000000..9b6c508c7
--- /dev/null
+++ b/main/py-ttystatus/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=py-ttystatus
+_pkgname=${pkgname#py-}
+pkgver=0.23
+pkgrel=0
+pkgdesc="Terminal progress bar and status output for command line"
+url="http://liw.fi/ttystatus/"
+arch="noarch"
+license="GPL3+"
+depends="python"
+depends_dev=""
+makedepends="py-setuptools"
+install=""
+subpackages=""
+source="http://code.liw.fi/debian/pool/main/p/python-ttystatus/python-ttystatus_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bfc43748b5a569a0d5e283b2e78814a8 python-ttystatus_0.23.orig.tar.gz"
+sha256sums="1ecd58dff0049fdccedb6cd41ff0ddc51971c943e8d1887f8c027ae9e3aeb17a python-ttystatus_0.23.orig.tar.gz"
+sha512sums="29dd9ee0a063b4f49c72a1f08acfe80f4db9b3a374b1424a98926d25e22c8df0ed89441997322556edaad03a339dafdbf874a1247f095f1f857ef04f90b8a040 python-ttystatus_0.23.orig.tar.gz"