summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-31 06:01:18 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-31 06:01:18 +0000
commitcd2c0b9f6011465e358ee1fd5cbebb9c6b4b44e6 (patch)
tree2d843713eb81e9c138271d23da8c109e80192aa4 /testing
parent94e964811fcc6d2d92189d6675061b5774188538 (diff)
downloadaports-cd2c0b9f6011465e358ee1fd5cbebb9c6b4b44e6.tar.bz2
aports-cd2c0b9f6011465e358ee1fd5cbebb9c6b4b44e6.tar.xz
testing/obnam: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/obnam/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/obnam/APKBUILD b/testing/obnam/APKBUILD
new file mode 100644
index 000000000..812629674
--- /dev/null
+++ b/testing/obnam/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=obnam
+pkgver=1.8
+pkgrel=0
+pkgdesc="A backup program that supports encryption and deduplication"
+url="http://obnam.org/"
+arch="all"
+license="GPL3+"
+depends="python py-larch py-paramiko py-fuse"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://code.liw.fi/debian/pool/main/o/$pkgname/${pkgname}_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7838a2678f2a0d10d88247450245787f obnam_1.8.orig.tar.gz"
+sha256sums="f70469c29e3d16c7080dffb433c8027ea5f2fb8f0112cd7b32b83958ccf72005 obnam_1.8.orig.tar.gz"
+sha512sums="02752227eda5d73e5ad292ea2347e5c7cf1a86b7a6c08cc9f3471a3d50f2c2b181fdb326aa0bf55d920a6c5a653aa9e4a7601b895774de33dd950dec767ee9fb obnam_1.8.orig.tar.gz"