summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-28 12:15:53 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-28 12:19:14 +0000
commite9647b358bf442e215330e225effb2141f05bbfa (patch)
treede7b2b6d80444bf6b49be9561509ce320d3b1b8e /testing
parent6b8500740c53166c4a655cff2cc068b12be3e709 (diff)
downloadaports-e9647b358bf442e215330e225effb2141f05bbfa.tar.bz2
aports-e9647b358bf442e215330e225effb2141f05bbfa.tar.xz
testing/fcgiwrap: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/fcgiwrap/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/fcgiwrap/APKBUILD b/testing/fcgiwrap/APKBUILD
new file mode 100644
index 000000000..44fc3fc96
--- /dev/null
+++ b/testing/fcgiwrap/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=fcgiwrap
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Simple server for running CGI applications over FastCGI"
+url="https://nginx.localdomain.pl/wiki/FcgiWrap"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev autoconf libtool automake fcgi-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gnosek/$pkgname/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+
+ autoreconf --install && \
+ ./configure --prefix=/usr --mandir=/share/man --sbindir=/bin && \
+ make
+}
+
+package() {
+ cd "$_builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d14f56bda6758a6e02aa7b3fb125cbce fcgiwrap-1.1.0.tar.gz"
+sha256sums="4c7de0db2634c38297d5fcef61ab4a3e21856dd7247d49c33d9b19542bd1c61f fcgiwrap-1.1.0.tar.gz"
+sha512sums="b8d35762d1d3c94a67602290b0092f0c38cffbbcd3dbc16597abf8b92172909b04450c238de2e430e841a17dd47fdd48d6a001f77539966980ef1af61e447ddc fcgiwrap-1.1.0.tar.gz"