summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-07-29 20:16:21 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-07-29 20:16:21 +0200
commitf48523dcc064e0dca8e1c02845fc1fa8967bf794 (patch)
treeae9457bcc184901e87f0ccb0b2db8bca5b0f6fc9 /testing
parent6ac47f18fe7ceeec2a4838904b51d395af38fdd4 (diff)
downloadaports-f48523dcc064e0dca8e1c02845fc1fa8967bf794.tar.bz2
aports-f48523dcc064e0dca8e1c02845fc1fa8967bf794.tar.xz
testing/spacefm: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/spacefm/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/spacefm/APKBUILD b/testing/spacefm/APKBUILD
new file mode 100644
index 000000000..24bc7db1c
--- /dev/null
+++ b/testing/spacefm/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=spacefm
+pkgver=0.9.4
+pkgrel=1
+pkgdesc='Multi-panel tabbed file manager'
+arch=all
+url='http://ignorantguru.github.com/spacefm/'
+license='GPL3'
+depends='bash'
+makedepends='intltool gettext-dev gtk+3.0-dev udev-dev'
+subpackages="$pkgname-lang"
+source="https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-pixmaps || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="daeee7dcccea33d6258a0a9d783470c4 0.9.4.tar.gz"
+sha256sums="adca07a487ba75f5226a0f355df2c5cf080987b58fb38cc3475eac7f4a131b1a 0.9.4.tar.gz"
+sha512sums="a3aa745769c9baddbf15cfb4ca87c29e8ed52002a8865dc72772e9e11b1395938e2916e47238de4601393a326d2b38e9cd716a09f06e90caa7ede5724b18dedf 0.9.4.tar.gz"