summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-05-31 11:17:52 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-05-31 11:17:52 +0000
commit6ea5ce68141da139c8f247e2633d801405c4cc5f (patch)
treef88e34a6b98866c5c01dae6c4687bc0a6476929b /unmaintained
parent35033e272ded059190516be6d51b8e39193e4fb1 (diff)
downloadaports-6ea5ce68141da139c8f247e2633d801405c4cc5f.tar.bz2
aports-6ea5ce68141da139c8f247e2633d801405c4cc5f.tar.xz
testing/lua-lmd5: moved to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/lua-lmd5/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/lua-lmd5/APKBUILD b/unmaintained/lua-lmd5/APKBUILD
new file mode 100644
index 000000000..269f66192
--- /dev/null
+++ b/unmaintained/lua-lmd5/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-lmd5
+pkgver=5.1.2011.03.24
+pkgrel=0
+pkgdesc="A message digest library for Lua based on OpenSSL"
+url="http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/#lmd5"
+arch="all"
+license="Public Domain"
+depends=
+makedepends="lua-dev openssl-dev"
+install=
+subpackages="$pkgname-sha"
+
+# seems like they just update the upstream source package. Version is found in
+# luuid.c
+# For date and checksum see:
+# http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/release.txt
+
+source="http://dev.alpinelinux.org/archive/lmd5/lmd5-$pkgver.tar.gz"
+#source="http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/5.1/lmd5.tar.gz"
+
+
+_builddir="$srcdir"/md5
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make digests LUABIN=/usr/bin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ local cmod=$(pkg-config --variable INSTALL_CMOD lua)
+ mkdir -p "$pkgdir"/$cmod
+ cp -a *.so "$pkgdir"/$cmod/
+}
+
+sha() {
+ local cmod=$(pkg-config --variable INSTALL_CMOD lua)
+ mkdir -p "$subpkgdir"/$cmod
+ mv "$pkgdir"/$cmod/sha*.so "$subpkgdir"/$cmod/
+}
+
+md5sums="bc336a560b7b6513982c17eec9692bd6 lmd5-5.1.2011.03.24.tar.gz"